Loading...

Command Center RX

View device status, toner levels, and paper availability through web browser.

TAKE COMMAND OF YOUR DEVICES

Since MFPs are vital to your daily operations, you may want to know the status and current capability of your devices. KYOCERA’s Command Center RX enables users to view toner levels, paper availability and edit device status over the web browser by authorized administrators. You can even download print drivers directly from Command Center RX link.

Command Center RX puts you in command of your KYOCERA MFPs.

BENEFITS

  • Provide information like device status, toner levels, paper availability to all users
  • Set authentication to prevent unauthorized users from changing MFP settings
  • Allow administrators access to device settings and create new folders including address book, document box, device drivers and etc.
  • Access easily by entering device IP address into web browser
  • Provide secure access with HTTPS
  • Standardize on all KYOCERA TASKalfa MFPs and other ECOSYS models

HIGHLIGHT

  • As a web server that built into the printing device, allows you to verify the operating status and configure device settings related to security, network printing, email transmission and advanced networking
  • Remotely track paper and toner usages; Monitors jobs, and manages document boxes and address books
  • Allow to build an address book of most commonly used email contacts that is accessible from the control panel – for quick and error-free scan and send.
  • Able to arrange settings similar to another MFP’s settings
  • Use IE to login, can remote control the setting instead of change settings on MFP control panel
  • Document can be downloaded as JPEG, TIFF, PDF format

SYSTEM REQUIREMENTS

  • Protocols: The TCP/IP protocol is installed on the PC
    An IP address is assigned to the printing system
  • Web Browser: Microsoft® Internet Explorer 7.0 or later
    (Operates on Windows® XP/ Vista/ 7, Windows® Server 2003/ 2008)
    Mozilla firefox 3.5 or later
    Safari 4.0 or later (Operates on Apple Mac OS x 10.4 or later)